Some iTunes songs on my iPhone are grayed out and unplayable on Sonos

  • Problem
  • Updated 1 month ago
  • Solved
Some iTunes songs are grayed out and unplayable in the Sonos listing from my iPhone. I thought it was due to DMP but I got iMatch, deleted the unplayable songs and then downloaded them again. Same result, even though I updated my music index in Sonos. Any suggestions?
Photo of FrankF

Frank

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 28
Photo of Lesli T

Lesli T, Official Rep

  • 114 Posts
  • 11 Reply Likes
Official Response

Greyed out tracks in your Sonos library are unavailable to play, likely the result of a format issue.

If you purchased these songs from iTunes, it is possible that they are protected tracks.

Before 2009, iTunes purchased music was copy-protected using a form of Digital Rights Management (DRM). The DRM protection prevented this purchased music from being played through any non-Apple devices, including the Sonos Wireless HiFi System.  Songs that are protected by DRM, or are in a protected AIFF format, will not appear as valid selections in the Sonos App.

In order to play tracks from your mobile device, such as from “This iPhone”, the tracks need to be in AAC or MP3 format, and not in a protected format such as DRM.

How do I fix this?

  1. Check that tracks are in the right format in iTunes by hardwiring the iPhone into the computer.

  2. If they are protected by DRM (Digital Rights Management), the following link has all the information you should need about upgrade your DRM tracks through iTunes:  http://support.apple.com/kb/HT4914

In some cases, iTunes “album only” tracks may show up as DRM protected, but there is a workaround:

  1. Instead of downloading the usual .m4a file format, the 'album only' songs download in the .m4p format instead. This extension was previously used to denote tracks protected with DRM but these tracks are not DRM protected.

  2. Any recently downloaded purchase with the .m4p extension can be converted to .m4a by renaming the file or by using the iTunes right-click menu option "Create AAC version". The .m4a files will play properly through Sonos.

If none of the above helped, please create a new conversation with:

-a description of the problem

-a system diagnostic